Page 1 of 1

BUB trouble

Posted: Thu Mar 04, 2010 9:06 pm
by michael2010
Hi,

I'm trying to use the USB BUB board to connect to a slimmed down Arduino (I know it is just an Atmega168 with the Arduino bootloader) on a bread board. I used the following instructions as a template and have a working setup. http://itp.nyu.edu/physcomp/Tutorials/ArduinoBreadboard

What I can't seemed to get working is to get the USB BUB to talk to my setup. I have checked the USB BOB with a RBBB, chip, USB BUB and USB cable work fine. The chip has the Arduino scratch for LED blink on pin 13. When I power all up it works fine.

When, I now connect the USB BUB with my setup I can't get it to communicate.

I have the following connections:
USB BUB ---> Arduino
RX ---- TX (pin 3)
TX ---- RX (pin 2)
5 V + GND from external source to Arduino.

What do it do with the DTR?
Do I have to connect 5V and GND from USB BUB to Arduino?

I get the following message from the Arduino environment 0018.

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I tried this on a MAC (10.5) and PC (Win XP SP3) and get the same results.

At this point I can't believe that my setup works just fine but I can't figure out what I do wrong in regards of using the USB BUB.

Can someone please point me in the right direction? I have tried quite a lot of combination's not with success. What am I missing?

Thanks.

Regards, Michael

Re: BUB trouble

Posted: Fri Mar 05, 2010 8:30 am
by paul
Michael,

You're almost there.
You need to connect the BUB's ground to ground
Then connect the DTR line to reset - pin 0. There should also be a 10 K resistor on pin 0 connected to 5 volts at the other end.
That should get you going.

Paul

Re: BUB trouble

Posted: Fri Mar 05, 2010 5:35 pm
by michael2010
Paul, thank you so much. It worked right out of the box. I would have never guess the part with DTR and I did not real read anything anywhere. Thanks for the help. Two long nights have a great conclusion. :-) Michael