Page 1 of 1

BBB not uploading

Posted: Sat Jan 21, 2012 4:22 pm
by Legot
I have the BBB and have not been able to upload.
Every time that I try to upload it gives me the error

Code: Select all

avrdude: stk500_getsync(): not in sync: resp=0x00
and I'm not sure why.

I'm using this USB connection ... ORS%3A1123 And I'm fairly confident that I have everything connected properly.

The board is getting power, and I have tried switching the RX and TX connections (just in case). I have also tested the USB connector with PuTTY and it is responding so I really don't know what's wrong.

In the arduino program I've also tried to change the board from a 328p Duimanlove to an Uno, but that didn't change anything.

For the moment, the board is just doing what seems to be the "Blink" program, but that was just default on the board, I've been trying to load "Fade"

I really have no clue, as this is my first micro-controller board.

Re: BBB not uploading

Posted: Sat Jan 21, 2012 9:43 pm
by paul
I can't speak to your upload chip / scheme because I haven't used it.
Here are some things to try.
Verify that your upload dongle shows up as a serial port in Arduino. (Install the latest drivers)
Verify power and ground leads.
Verify the position of DTR or RTS pin. If the comm board you're using uses RTS signal then you may need to set COMM PORTS -> Virtual USB port -> Advanced -> Set RTS on close in Device Manager if you're using Windows.

Swap RX and TX (you won't hurt anything) if you're not sure. The RX and TX labels on the BBB board are reversed - meaning that they should be the labels on the upload chip. The RX pin label at the FTDI jack really goes to the Atmega TX - and vice versa

You probably want the Duemilanove settting in Arduino - unless you bought your board in the last week or so - We're shipping Optiboot now.
It won't hurt to try both settings though, you're not going to hurt anything.

Hope that helps,
Let me know how you make out with that dongle,


Re: BBB not uploading

Posted: Mon Jan 30, 2012 11:27 pm
by Legot
Ok, so I finally got this working!

I studied the schematic for the CP2012 chip, which is the core of this little dongle, and looking at it and the dongle it had a pin labeled RST and one labeled DTR

The DTR pin was apparently not used on this dongle, but the RST pin went to the RST header pin.
So I had to solder a capacitor to the DTR pin to the RST header pin, and it worked!

I ended up cutting the trace between the RST pin (on the chip) and the header, but it isn't necessary.

So if you're looking at this in the future, and you're using any non-standard usb to ttl dongle, then make sure that the DTR pin is being used, not the RST pin.

I also tested it with other sizes of caps, and any that is <1uf seems to work.

Paul, I also must note that the bootloader (idk which one I have) on this atmega328p waits less than half a second for an upload reset. Thus rendering a manual reset virtualy impossible. (It doesn't matter if you have a properly working auto reset though :D )

Edit: Here's a link that I found chip and circuit is the exact same, but just different component labels and orientations.

Re: BBB not uploading

Posted: Wed Feb 15, 2012 3:55 pm
by paul
Glad to hear about the victory!