Page 1 of 1

avrdude: stk500_recv(): programmer is not responding

Posted: Wed Apr 11, 2012 3:42 pm
by PennyLane
Hi,

I get the error " avrdude: stk500_recv(): programmer is not responding" when I try to upload sketches to my RBBB. I'm using an USB-BUB II to connect and am on a Core 2 Duo MacBook with MacOSX 10.5.8.

I have installed the FTDI drivers. My settings in the Arduino software are /dev/tty.usbserial-A900TRBN and Arduino Uno.

When I try to upload the RX LED on the BUB blinks once, then the TX LED blinks three times and then I get the error message.

Any suggestions?

Thanks for your help,
PennyLane

Re: avrdude: stk500_recv(): programmer is not responding

Posted: Wed Apr 11, 2012 4:41 pm
by paul
PennyLane,

Try the Duemilanove settting too - in case your board is an older one. Other than that - check the solder connection on BUB header and RBBB header. Confirm RBBB resistors are correct, check some voltages on the RBBB.

Paul

Re: avrdude: stk500_recv(): programmer is not responding

Posted: Sat Apr 21, 2012 6:45 am
by PennyLane
Hi,

I tried the Duemilanove setting, no success.

I checked the solder joints on my board and found that 5V and RX are connected. Could it be that this is causing my problem or is it OK?

Re: avrdude: stk500_recv(): programmer is not responding

Posted: Sat Apr 21, 2012 1:58 pm
by paul
PennyLane,

What do you mean that "5V and RX are connected"? If you unplug the board and put a meter on it set to continuity does it beep?
They are visually connected? They definitely should not be connected.

Give me some more details, or post a picture or just try to unconnect them.

The RX line will probably measure "high" (around 5V) with a meter, when nothing is happening. This is normal. But when the board is disconnected the RX line should definitely NOT show close to zero ohms resistance when measured to the 5V line.

Paul

Re: avrdude: stk500_recv(): programmer is not responding

Posted: Sun Apr 22, 2012 3:04 am
by PennyLane
Yes, I meant it shows 0 ohm when I measure 5V against RX. So the problem seems to be somewhere around there.

Re: avrdude: stk500_recv(): programmer is not responding

Posted: Sun Apr 22, 2012 6:59 am
by PennyLane
I finally fixed it. The error was that I soldered the header pins of the RBBB onto another board because my RBBB is part of a larger project. This is where I connected 5V and RX (which is actually TX there).

Lessons learnt: Think before you solder :lol: