Wind Sensor

Questions about Modern Device and JeeLabs Sensors
Post Reply
LVX
Posts: 2
Joined: Fri Oct 24, 2014 2:07 am

Wind Sensor

Post by LVX » Fri Oct 24, 2014 2:36 am

Dear Paul,

I'm building a wind sensor based on your device rev c (as I'm aware now that there is a rev p).
Everything is working as aspected. I'm using a spark core (wifi enabled development board) for reading the analog pins.

I'm running for severals days now to fill my dataset. And now I'm trying to implement your second order polynomial that you derived from your dataset.
Now things are getting fussy, as I'm not getting values I would like. I'm trying to derive the TMP read out at first, to see if it is reading room temperature correctly. But it isn't.

In your excel plot the x- and y-labels are missing, that leaves me to guess what you are doing there.
http://moderndevice.com/wp-content/uplo ... .10-PM.png
In your Arduino sketch you are only using the analog read is a variable: TempCtimes100 = (0.005 *((float)TMP_Therm_ADunits * (float)TMP_Therm_ADunits)) - (16.862 * (float)TMP_Therm_ADunits) + 9075.4;
So, are you plotting analog read (V) against temperature (C)? Or is it something different?

I'm also wondering at what resolution you are reading the analog pins, the SparkCore is reading them at 2^14, so 5volts devided by 2^14 = 0,00122070313V per step. Maybe that is a difference in my sketch.

Best regards,
LVX

paul
Site Admin
Posts: 735
Joined: Mon May 12, 2008 4:19 pm

Re: Wind Sensor

Post by paul » Fri Nov 07, 2014 8:32 am

LVX

Here is how I did my regressions.
Put your data into excel. for example voltage vs wind speed

Subtract the zero wind value from the whole column.
Plot a scatterplot chart.
Add trendline and use the exponential function, check the show formula.
You now should have a pretty decent fit to the curve - just add back in the zero wind speed as another term in your formula.

There is a URL for Cambridge University on my blog that I found really useful for the math.

Hope that helps,

Paul

donalg
Posts: 2
Joined: Wed Jan 28, 2015 5:58 am

Re: Wind Sensor

Post by donalg » Wed Jan 28, 2015 6:30 am

Hi All,

In my application, I am looking to measure wind speed in a working/office environment. The expected wind speed is within the range of 0.1m/s to 1.0m/s.
Will this sensor be able to pick these speeds reliably?
Also do you think that this sensor operates in an omni-directional manner or does the speed value vary with the direction?

Post Reply